View Menu

Navigation:  Widget Designer > User Interface >

View Menu

prev main next

Navigation:  Widget Designer > User Interface >

View Menu

prev main next

Please wait. Due to its content this page might take a while to load...

The View menu in WD lists commands influencing the setup of your working environment.

wd_menu-bar_view
wd_view-menu_without-protect-interface

Reload
Reloads the current page.

Zoom
The maximum zoom factor is 300%, minimum 25%. To reset the zoom, press [CTRL + 0].

Grid
"Show Grid" will display a pattern in the background. In the "Settings" dialog you can adjust its size. With the "Snap to Grid" feature, you may use the (in-)visible grid as magnetic guides.

Widget Explorer
Opens the Widget Explorer dialog that displays a tree view of all items of your project.

Browse Page
Opens a browser where all pages created are displayed with a thumbnail and their name. This makes it possible to navigate easily through many pages. By clicking on one of the pages you will switch to it. You may open the page browser via a command: OpenPageBrowser

wd_page-browser

Find Entry
Opens a dialog where you may enter a (part) of a command.

"Scope" opens a drop-down list where you may choose to search the entire project or only on the current page / window.
"Find all References" starts the search and displays where the command was found, for example in a Custom Script Button, a Script Output node, a Function/Macro, or Page.
Right-click on the result to open the according properties or go to the page where it is located.

If you look for a tool that helps you debugging, i.e. finding errors in your command programming, open Tools > Options > Debug.

wd_find-entry

Find Item
Opens a dialog where you may enter a widget´s name.
"Goto Page" calls the page where the control is located.
"Show" will not switch pages but overlays them with the control. The control will flash three times and then stay in front of them until you go to its source page. Thus you may use the control or edit its item properties.

wd_find-item

Show Sticky Notes
Sticky Notes are only visible if enabled in the menu or by using [CTRL + ALT + N].

Show Hidden Controls
If there are any hidden widgets or nodes in the project, this option opens a dialog where all hidden items are listed. You can choose which ones of them you want to be visible again.

Kiosk View
This option removes all bars and menus and resizes the main GUI to full screen. For leaving the Kiosk mode, press [F11] again. Additionally, you can decide whether to use the [ESC] key for exiting Kiosk mode.
The Kiosk view gives you the largest available space to arrange any controls forming an individual user interface.

Full Screen
Maximizes the WD window over the whole screen and hides the standard Windows border and application title bar for sure. You may as well use the shortcut [CTRL + 1]

Maximize
Maximizes the WD window over the whole screen. Shortcut: [CTRL + 2]

Normal Size
Brings the WD to the size and style it had before maximizing, or the default window size of 800x600px. Shortcut: [CTRL + 3]

Minimize
Minimizes the WD window. Shortcut: [CTRL + 4]

Close Window
Closes the current WD window. If there is no other window opened, the program will be closed after asking for the project to be saved.

Disable Interface
With "Disable Interface" you can disable all (!) mouse, touch and keyboard input and nothing can be clicked or entered anymore. When an input is detected, a Windows error sound is played. This mode is for example perfect for programmers who want to make sure, nobody changes the interface or clicks anything. You can enter and leave this mode with the shortcut [Pause]. Note that the [Pause] key differs from the [Play/Pause] key for the  Windows Media Player and cannot be found on all (hardware) keyboards anymore but it is available in the Windows onscreen keyboard.