Using an Object in Pandoras Box

Navigation:  Tools and Other Software > Warper > Warping Guide >

Using an Object in Pandoras Box

prev main next

Navigation:  Tools and Other Software > Warper > Warping Guide >

Using an Object in Pandoras Box

prev main next

Please wait. Due to its content this page might take a while to load...

This chapter explains how a single mesh can be exported from the Warper and be used in Pandoras Box. In the next tutorial there is an example with a project containing associated meshes.

When you finished your mesh, please export your file in order to use it in Pandoras Box. Choose File menu > Export Modes > Export selected.
A small browser window opens. Browse to the directory to where you want to export your mesh as an *.x-file.

It is highly recommended to always save the warping project too. Choose File menu > Save Settings. Whilst the exported *.x file contains only the mesh information, the *.wrp file saves all other settings and the FFD data. If the projector or a screen has moved, for whatever reason, or if you like to fine-tune / finalize your mesh, you can then simply load your warping project file (File > Load Settings) and make your changes.

Open your Pandoras Box application (Pandoras Box Manager, Player or Server). In the Assets tab browse to the directory to where you exported your mesh. Drag and drop this *.x-file into the Project tab. You might need to spread the file. If you have created this file for a specific output (e.g. Output 2), assign it to the according Output layer. Now all affected layers will be deformed in the same way. If you have created it for only one layer, assign it to an available Graphic or Video layer. Both scenarios are depicted in the example below.

warper_meshexample_07This grid is exported as screen5.x. File menu > Export Modes > Export selected

preview_ex-with-mesh_01In Pandoras Box there are two layers in use - one for the blue background and one for the orange content. Currently there is no object assigned to any layer, neither to the content layers nor to the output.

The Preview tab is shown in the left image.

assets_project_drag-objectThe saved object screen5.x is dragged from the Assets tab into the Project tab. Now it is part of the project.

preview_ex-with-mesh_02device-control_output_meshThe Preview shows the result when the object is assigned to the Output layer, everything is mapped onto the object ...

preview_ex-with-mesh_03device-control_media-and-mesh...whereas this would be the result if the object was assigned to the orange layer, and not to the output. As you can see, only the orange layer is deformed, the blue background keeps its original shape.

Please note that it is possible to combine these two ways: you might assign an object to a layer and to the output at the same time. Then, the image will be deformed twice.