PB VNC Remote

Navigation:  Tools and Other Software >

PB VNC Remote

prev main next

Navigation:  Tools and Other Software >

PB VNC Remote

prev main next

Please wait. Due to its content this page might take a while to load...

This chapter describes the application "Pandoras Box Remote" which is a VNC software that allows you to remote control another computer.

PB Remote can connect to any computer in the network that launched the corresponding VNC Server. You simply enter the according IP address and see the desktop of that computer in a window. Now you can use your local mouse and keyboard to interact with the remote desktop.
Both, the VNC connection software PB Remote (VNC Client) and the VNC Server are part of the default PB Menu installation. Whilst the software is started with the "Remote" button, the VNC Server automatically runs in the background when the PB Menu is started.
PB Remote also offers a good overview of all (PC) devices in the network and as seen in the image below, you can depict a computer as an icon on the page showing necessary information and status updates. Eventhough you can download Pandoras Box Remote separately from the Download-Center on our homepage this manual assumes that PB Menu runs on the other system in order to transmit all information properly.

It might be of interest that Widget Designer offers two input nodes displaying software and hardware information of remote computers. The "PB Menu" Input Node receives information from the PB Menu and "Engine Health" from Pandoras Box. Please find more information in the linked chapters.

The chapter starts with "Daily Use": a short description of steps most operators do when using PB Remote. Then there is a short Troubleshoot paragraph and afterwards, all menus and dialogs are explained.

 

File

Edit

VNC

Commands

Tools

Other Commands

 

remote_main-gui_zoom30click to enlarge

Daily Use

Connect to and disconnect from another computer via VNC
Enter the IP address from the remote system into the "VNC" drop-down list in the menu bar and press [Enter].
Per default, you now see the desktop of that computer in a window and you can use your local mouse and keyboard to interact with the remote desktop.
Alternatively, if you added systems to a page already, simply double-click one to connect to it.
Click the "Disconnect" button in the Menu bar to stop the VNC connection.

Get an overview of all systems in the network
Right-click into the page background (or use the Tools menu) and choose "Server Control".
All systems are listed with their according network and output information and offer a right-click menu.

Add a system to a page
Right-click into the page background and choose "Add System".
Enter the IP address and a name if you like. The above depicted icons can be chosen with the "Type" drop-down.

Add all systems in the network to a page
Right-click into the page background (or use the Tools menu) and choose "Server Control".
Click the button "Add All to View" in the upper right corner and close the dialog.
Note that all systems are now in the center of the page and can be moved.

Move a system icon to another position
Enter the Move mode by either clicking the arrow cross symbol in the Menu bar or using the shortcut [Alt+M].
Left-click an icon and drag it to the new position.
If you like, enter the Select mode by clicking the cursor symbol in the Menu bar.

Send a command to a system
Right-click into the page background (or use the Tools menu) and choose "Server Control".
Right-click on a system and choose your command, e.g. "Close PB" or "Reboot".
Alternatively, if you added a system to a page already, simply right-click it there.

Send a command to all systems in the network
Open the Commands menu and choose one of the "All" commands, e.g. "Close All PB Clients" or "Reboot All"

Troubleshoot

VNC Connection failed
- verify that you typed in the correct IP address
- check whether the system is listed in the "Server Control" dialog
- make sure that the remote computer launched the PB Menu and that the VNC Server process is running (check icon in the System Tray), try to reset both, e.g. using the right-click menu in the "Server Control" dialog
- try to ping the other computer
- check the local and remote network settings
- verify that PB Remote is set to the correct network adapter
- verify whether PB Menu lists the correct IP addresses

No mouse or keyboard input
- make sure that "Viewer Only" in the VNC menu is deactivated
- press the "Exit Fullscreen" as some systems do not transmit their fullscreen desktop via VNC

Commands are not executed or status is not correct
- check whether all systems are listed in the "Server Control" dialog
- make sure that the remote computer launched the PB Menu, try to reset it, e.g. using the right-click menu in the "Server Control" dialog
- try to ping the other computer
- check the local and remote network settings
- verify that PB Remote is set to the correct network adapter
- verify whether PB Menu lists the correct IP addresses

File Menu

remote_file-menu

New
This opens a new empty project.

Open Project
This opens a file dialog where you can pick an already saved PB Remote project with the file extension .pbr

Save Project
This opens a file dialog to choose a name and pick a location to save the current PB Remote project.

Save VNC Screenshot
This command works only if you established a VNC connection to another computer. It opens a file dialog to choose a name and pick a location to save a screenshot from the remote desktop.

Exit
This closes the application. Note that all icons on the page are loaded again when starting PB Remote later even if you have not saved the project.

Edit Menu

remote_edit-menu

Connections
This opens the Connections dialog which is described further down.

Reset IP List
This deletes all systems (i.e. their icons) from the project.

Create Page
This creates a new page with a custom name.

Rename Page
This allows to enter a new name for the current page.

Delete Page
This deletes the current page.

remote_edit-menu_connections

The Connections dialog can be opened with Edit > Connections.

Add
This opens the "New Connection" to dialog to add a system as an icon to the page. Its settings are described further down.

Delete
This deletes the system (with the IP address from the drop-down list) from the project. You can also delete a system by right-clicking the according icon on a page and choosing "Delete system".

IP address drop-down list
The drop-down list offers all IP addresses from system that are already added to the project (as icons) but you can also type in an IP address. The buttons "Delete", "VNC Connect" and "FTP File Upload" refer to this address.

VNC Connect
This opens a VNC connection to the system with the IP address from the drop-down list. You can also connect to a system by double-clicking the according icon on a page or by entering an IP address into the drop-down list in the menu bar and pressing [Enter].

Per default, you now see the desktop of that computer in a window and you can use your local mouse and keyboard to interact with the remote desktop.
The VNC menu offers commands like "View Only" or "Auto Scale". The Menu bar includes the buttons "Exit Fullscreen" and "Disconnect" to stop the VNC connection again.

Of course, the connection can only be established when the other system is online and the PB Menu or, more precisely, the PB VNC Server is running.

FTP File Upload
This opens the "FTP Media Upload" dialog that allows to add media files to a remote PB project. Its settings are described further down.

Server Control
This opens the "Server Control" dialog that allows to view all connected systems with their network and output settings. The dialog is described further down. It can also be opened with the Tools menu or from the menu  that opens when you right-click in the empty background of a page.

remote_ftp-file-uploadThe "FTP Media Upload" dialog can be opened with Edit > Connections > FTP File Upload or from the right-click menu from an icon on a page.

The dialog shows information from the Pandoras Box project loaded with the master system you are connected to and allows to transfer files from your local system. It mainly consists of the Project tree, i.e. all folders and files loaded in Pandoras Box. There are two buttons above and below the Project Tree, and there is a context menu that opens when you right-click the tree. Note that there is also an "FTP Client" feature in PB Remote. In case, one of the FTP features does not work,  make sure that the FTP Server process is running on the remote system.

Save Project
This saves the Pandoras Box project under the current name.

Upload File
This opens a dialog where you can pick a media file from your local system that should be transferred to the remote system. It is saved on its hard disk and added to the Pandoras Box project. If you right-click a specific folder, before choosing the command, the file is added to this folder.

Upload Folder
This opens a dialog where you can pick a folder from your local system that should be transferred to the remote system. It is saved on its hard disk and added to the Pandoras Box project. If you right-click a specific folder, before choosing the command, the new folder is added to this folder.

Upload File With ID
This opens a dialog where you can pick a media file from your local system that should be transferred to the remote system. It is saved on its hard disk and added to the Pandoras Box project. If you right-click a specific folder, before choosing the command, the file is added to this folder. In addition you have the possibility to enter a File and Folder ID for this file. Note that choosing an already existing ID will assign it to the new file whilst the previous media will not have an ID anymore.

Upload Folder With ID
This opens a dialog where you can pick a media folder from your local system that should be transferred to the remote system. It is saved on its hard disk and added to the Pandoras Box project. If you right-click a specific folder, before choosing the command, the new folder is added to this folder. In addition you have the possibility to enter a starting File and Folder ID for all files included in the folder. Note that choosing an already existing ID will assign it to the new file whilst the previous media will not have an ID anymore.

Set File Folder ID
This opens a dialog where you can enter a File and Folder ID. Note that choosing an already existing ID will assign it to the new file whilst the previous media will not have an ID anymore. You can assign a File and Folder ID to a specific file in the project but also to an entire folder. In that case, the chosen File and Folder ID is a starting ID and increments with every file.

Remove Media
This removes the file or folder from the Pandoras Box project but does not delete it from the hard drive.

Delete Media
This removes the file or folder from the Pandoras Box project and deletes it from the hard drive.

Refresh
This refreshes the Project Tree.

Upload Progress and Abort
This shows the progress of the file transfer which can be stopped with the Abort button.

VNC Menu

remote_vnc-menu

View Only
This influences the VNC connection. Per default, you see the remote desktop in a window and send your local mouse and keyboard data to interact with the remote desktop. The "View Only" option stops the mouse and keyboard data. To send them again, untick the option once more.

Auto Scale
Per default, the remote desktop is scaled to fit horizontally and vertically into the local VNC window. Uncheck the option "Auto Scale" to see the native remote desktop resolution and to use scrollbars in case it is larger than your window.

Refresh
This refreshes the current VNC Connection.

Commands Menu

remote_commands-menu

The Commands Menu includes commands that can be sent to the system with the IP address from the drop-down list to the right.

Note that the Server Control dialog (Tools > FTP Client or from the right-click menu from an icon on a page) also offers commands for the system you right-clicked on. First, the command is send only to this system and second, you can find some other commands, e.g. referring to the FTP Server and output resolution.

remote_commands-menu_pb

Start Master & Client
This starts the configured Pandoras Box version in master mode or client mode. To choose a Pandoras Box version, go to the remote PB Menu "Configuration > Pandoras Box".

Close PB
This closes the current PB application without saving the project.

Restart Master & Client
This closes and starts the configured Pandoras Box version in master mode or client mode.

All commands
The "All" commands are send to all systems in the network running the PB Menu.

remote_commands-menu_system

Reboot, Standby and Shutdown
This executes the according Windows functions.

Reset Menu & VNC Server
This closes the according process and restarts it again.

All commands
The "All" commands are send to all systems in the network running the PB Menu.

Start Task Manager
This starts the Windows Start Manager.

remote_commands-menu_setup

Set Date / Time
This allows to change the timezone, date and time of the remote system.

Set Date / Time All
This allows to change the timezone, date and time of all systems in the network running the PB Menu.

Tools Menu

remote_tools-menu

FTP Client
This opens the below described dialog to send files from your local computer to a remote one. Note that there is also an "FTP Media Upload" feature in PB Remote that allows to upload files to a PB project directly.

Server Control
This opens the "Server Control" dialog that allows to view all connected systems with their network and output settings. The dialog is described after the one from FTP Client.

remote_ftp-client_zoom51click to enlarge

The "FTP Client" dialog can be opened with Tools > FTP Client or from the right-click menu from an icon on a page.

To connect to the FTP Server running on a remote computer, enter the login credentials in the upper part of the dialog starting with the remote IP address. The FTP Username and Password can be set up on the remote computer. The PB Menu has a predefined user "admin" with the conforming password "admin". Port 21 is a default for FTP connections and should only be changed if necessary. Follow the link for more information about the FTP setting in the PB Menu chapter.

Now you see your local file structure on the left side and the remote access folder on the right one. To upload files, simply drag folders or files from one site to another. Note that there is a status bar next to "FTP Site" that shows the upload progress of the file transfer. You can abort it with the according button next to it.
The right-click menu of an item offers the options to refresh or delete it.

remote_server-control_zoom38click to enlarge

The Server Control dialog can be opened with Tools > Server Control or from the right-click menu from a page.

With the button "Scan Network" you can refresh the below table with all computers in your network running the PB Menu.
With "Add All to View" you can add each system as an icon to the current page. Note that a system can only exist once per project. All icons are now in the center of the page and can be moved. Enter the Move mode by either clicking the arrow cross symbol in the Menu bar or using the shortcut [Alt+M]. Left-click an icon and drag it to the new position. If you like, enter the Select mode by clicking the cursor symbol in the Menu bar.

The table lists all systems and their according information:
- the computer's name
- IP and Mac Address of the first network card (and the second if existing)
- the resolution of Output 1 and 2
- the graphics card's desktop setup
- the status of running PB software (Master, Client or None)
- the Server's graphics card model
- the status of the FTP Server

If you right-click an entry, you can select a command to control this device.

Commands in Menu Bar

remote_title-bar_1

Clicking on "?" shows the version of the currently running Remote application. The "Cursor" activates the selection mode where you cannot drag items on the page background. The "arrow cross" icon activates the Move mode where you can click on items on the page background and drag them to a new location.

remote_title-bar_2

Choose or enter the IP address from a system. If you are not using the default port 5900, you can use the syntax "IP:port", e.g. "2.0.0.1:5905" to specify the port. Now you can either send a command from the Commands Menu described above or hit the [Enter] key to start a VNC connection.

remote_title-bar_3

Hit the "Disconnect" button to stop the current VNC connection.

remote_title-bar_4

Choose a page in the drop-down list to jump to it.

remote_title-bar_5

This works only for a system you are already connected to via VNC. It closes the fullscreen mode of the running PB Master or Client and switches to the windowed mode. Note that under Win8 a fullscreen window can not be transferred via VNC anymore, and instead you see the background behind the window.

remote_title-bar_6

Choose the local network adapter to define the network in which the PB Remote should work. The IP address to the right displays the local IP.

The Page and its Context Menus

You can right-click an icon on a page or the empty background to choose a command. By the way, double-clicking an icon, starts a to start a VNC connection.

remote_main-gui_context-menusPlease find above the description for:
- commands
- VNC Connect
- FTP Media Upload
- FTP Client
- Server Control

Per default, the project offers an empty "Default" page. If you like, you can add more pages (Edit menu) and you can switch to them using the Page drop-down in the Menu bar.

You can add systems to a page that are visualized as small icons depicting various computer models. In addition, information surrounds this icon, e.g. the IP address or the status:
- Offline: the system cannot be found in the network; the icon background is transparent
- Online: the system is available in the network and a VNC or FTP connection are possible, but Pandoras Box is not running; the icon background changed to solid gray
- Master or Client W / F: in addition to being online, the system has started the Pandoras Box Master or Client application which is running in windowed mode ("W") or is toggled into fullscreen ("F")

As described in the beginning (see "Daily Use") there are two ways to add one or multiple systems to a page. If the system is already online, the "Add All to View" button and "Add to View" command from the Server Control dialog offer a fast workflow. The alternative is, to use the "Add System" function available in the right-click menu from the empty page background or under Edit > Connections and choosing "Add System".

remote_add-systemIP

Enter the IP address from the computer you like to add to the page. If you are not using the default port 5900, you can use the syntax "IP:port", e.g. "2.0.0.1:5905" to specify the port.

Name

Enter a name that should be displayed underneath the icon. If no name is entered, the original computer name is taken as soon as the IP address can be connected.

Type & File

The type is simply the icon that either depicts a tower PC, or a Dual Server etc. You can also choose "Custom" and a custom image with the [...] button next to "File". Note that an icon is scaled up or down to fit the icon size of 150x130px. In addition, it makes sense to choose an image with a transparent background so that the offline/online status is better visible and bear in mind that the information text added to the top and bottom of the image has a white font.

Page

Choose the page to add the system to.

Port, Root, User and Password

All these settings are default settings for the "FTP Media File Upload" and "FTP Client" and should accord to the FTP settings in the PB Menu on the remote system.

 

To delete a system from a page again, choose "Delete System" from its right-click menu. "Edit >Reset IP List" deletes all systems at once.