File Menu

Navigation:  Pandoras Box > User Interface - Master > Menu Bar >

File Menu

prev main next

Navigation:  Pandoras Box > User Interface - Master > Menu Bar >

File Menu

prev main next

Please wait. Due to its content this page might take a while to load...

The file menu allows you to achieve all project related actions.

menu-bar
menu-bar_file

New Project

Click here to create a new project. Before leaving the current project you will be asked if you want to store the current project. You will have to choose if you want to create a project in Standard Mode (shortcut: CTRL-N) or in Lighting Console Mode.

Open Project

Click here (or use CTRL-O) to open a dialog where you can choose the directory and name of a project saved in the PBB format. Older XML projects can be opened with the "Import Project" command.

Open Recent Project

This opens a list with recently used projects.

Save Project

Click here (or use CTRL-S) to save the current project. This also saves the project for all Multi-Users.
Please note: There is no auto-save function!

If you save the project the first time, a dialog opens where you can choose the directory and name for your project. Note that the "Pandoras Box Binary" format with the extension "pbb" is the new default and saves the project as a binary file. To use the older XML format, you need to "Export" the project. The advantages of a binary code are a smaller memory space and thus faster saving and loading.

Save Project As

Click here (or use CTRL-Shift-S) to save the current project under a different name and go on working in the renamed project. This also saves the project for all Multi-Users under the new name and switches their project to the new one.

Save Project Copy

Click here (or use CTRL-Shift-Alt-S) to save a copy of the current project and go on working in the current project. This is an ideal option for saving backup versions of your project. A nice workflow is for example to create a "Backup" folder in your project folder and choose this folder when saving with the "Save Project Copy" option. For a nice overview, you could name your copies with the date or with a description, e.g. "projectname_20170531_0815" or projectname_v10_before warping". If you like to load a project copy (or backup) and in case you work with content saved in the "assets" folder, it makes sense to copy or paste the backup file into the folder with the "assets" folder, i.e. next to the original project file as this ensures that your content is consistent. The benefit of the "assets" folder is explained in the next paragraph "Bundle Project".

Please note, that this saving option does not work in a Multi-User environment.

Import Project

This opens a dialog where you can choose the directory and name of a project saved in the older XML format. PBB projects can be opened with the "Open Project" command.

Export Project

This opens a dialog where you can choose the directory and name to save your project in the older XML format. The above options to save the project use the newer PBB format. The advantages of the "Pandoras Box Binary" format are a smaller memory space and thus faster saving and loading.

Bundle Project

Click here (or use CTRL-Shift-B) to bundle your project under a new name and location. All content used in the timeline will be copied to the new location in a folder called "assets" next to the show file. This option allows you to only have one folder to archive your show on a external hard drive. To play your show again, just copy this folder at its original location on your hard disk and all paths will be recovered.

Since version 5.5 Pandoras Box supports a relative path whereto content can be saved. When saving a project a folder named "assets" is generated just next to the show file. If you copy content files to that folder and drag them from here into your Pandoras Box project the content links are relative. That means that you can move the project folder ( including the *.xml and asset folder) to every path wanted without the need of re-linking the content.
As bundling the project creates an assets folder as well, you can copy the bundled folder wherever you like to. As all paths are relative paths, Pandoras Box is able to load all the content. It will not become inconsistent any more.

Close Project

Click here (or use CTRL-W) to close the current project.

Remove Unused Resources

Click here to remove all content files from your project that are not used in the timeline.

Clean up Inconsistent Resources

Use this command if you like to remove inconsistent resources from the Project tab.
Inconsistent resources are marked with a red exclamation mark. Click on one and check the Inspector. At the very bottom you see the file location table with at least one entry that says "inconsistent". This means that the file does not exist in that location any more. Under circumstances this might be alright and you could select the entry and click "Remove" to delete the entry from the table. If the table does not list inconsistent entries anymore, the file status changes to "consistent" again and the red exclamation mark is removed. In case you have many inconsistent files and you checked that this is "alright", you can simply use the command "Clean up Inconsistent Resources". This removes ALL "inconsistent" entries from ALL files. Bare in mind, that a file that is not present on any Site anymore will be removed from the Project tab and containers in the Sequence will be named "None" instead of the old file name.

Exit

Click here (or use CTRL-Q) to Exit Pandoras Box. You will be asked if you want to store your project if there are not stored changes.