Live Warping

Navigation:  Tools and Other Software > Warper > Warping Guide >

Live Warping

prev main next

Navigation:  Tools and Other Software > Warper > Warping Guide >

Live Warping

prev main next

Please wait. Due to its content this page might take a while to load...

The live warping feature (previously known as dynamic warping) allows to have non-static objects on a layer. While projecting, the mesh can be influenced in real-time. Another feature - Morphing  - allows to fade between two or three saved meshes.
Please note that those features are not available on Pandoras Box Player Systems!

Controlling Pandoras Box via Warper

warper_network-settings- In the Warper, set up the connection to the Pandoras Box (PB) Master system. To do this go to "Edit" > " Network Settings".

- For the next steps advanced features will be used, please go to "Edit" > "Advanced Mode" to toggle between the basic and advanced user interface where all features are visible in the menus and tabs.

warper_export-as-index- Set up the FFD and mesh count from your mesh you would like to use, or import an object.

- Export the selected mesh as an index object (as the previous mentioned step influences the object, the export has to be done each time you change the FFD and mesh count). To do this go to "File" > "Export Modes" > "Export Selected as Index Object". Save the *.x file. If the PB Master is connected and a project is opened, all exported objects will be automatically loaded into this project. If you start the project later drag and drop your saved object from the Asset tab to the Project tab.

warper_dynamic-dev-tree- In PB, choose which layer (or output) you want to warp live. First of all assign a media file to it and make sure the opacity is on.
Then go to the Project tab and assign the exported object as a mesh to the layer. The layer will now be stretched as if it was one line.
Go to the "Aeon FX" tab > Folder "Warp" > drag the effect "Warp" onto the layer. Note that this effect has no parameters, you will not see it in the Device Control itself. Only when opening the FX parameter in the Device Tree you see the effect. The effect cannot be turned off like other effects, the only way to deactivate it, is to delete it entirely.

warper_tabs_live-warp_ex-out - In the Warper, go to the tab "Live Warp", tick the check box "Enable Pandoras Box Warp Output" and set up the site and device whereto you assigned the object and the effect in PB.

- Now, as soon as you edit the FFD or mesh in the Warper the layer in PB will not look like one line anymore. From now on it is influenced in real-time according to the mesh in the Warper.

Controlling Warper via Pandoras Box / another Art-Net Device

- As this feature is based on an Art-Net communication make sure that Pandoras Box and the Warper are set to an IP address 2.x.x.x and Subnet Mask 255.0.0.0.

warper_warping-device- In Pandoras Box go to the "Device Types" tab  and open "DMX Fixtures" > "COOLUX"

warper_warping-device-in-dev-tree- and drag the "PB Warp 3x3.clib" into the Device Tree.

warper_warping-device-patchen
- Now select the warp device and go to the "Patch" tab to patch it, for example to Channel 1 on Subnet / Universe 1/1 .

- Lastly, go to the "Configuration" tab, open the section "Remote Control Protocols" and press the button Art-Net "Activate Output".

warper_tabs_live-warp_ex-in- In the Warper, set up a mesh with an FFD count of 3 x 3 and a mesh count of your choice.

- Go to the "Live Warp" tab, tick the check box "Enable Art-Net Input" and patch the Channel as done in the previous step.

- Now, as soon as you change the parameters within the warp device in PB, the FFD points and therefore the mesh are influenced.

- Instead of the warp device in PB you can use any Art-Net sending device to control the FFD in the Warper.

- Of course this feature can be combined with the above mentioned feature and the Warp FX. If you do this you are limited to a 3 x 3 FFD.

Morphing between several objects

warper_export-as-morph-target- In the Warper, first of all open the "Edit" menu and activate the "Advanced Mode". Then set up the FFD and mesh count. Export the mesh as an Index Object. This has to be done only once, as long as you do not change the FFD and mesh count anymore.

- Then deform the mesh as you wish to have it when starting the morph process.

- Export this state as the first Morph Target (as the previous mentioned step influences the file, the export has to be done each time you change the mesh). To do this go to "File" > "Export Modes" > "Export Selected as Morph Target". Save the *.png file. If the PB Master is connected and the Warper is set to its IP address and domain and if a project is opened, all exported objects will be automatically loaded into this project. If you start the project later drag and drop your saved object from the Asset tab to the Project tab..

- Do the same for the second (and third) status of the mesh. These states represent the in-between look or how you wish to have the deformation when the morph process is finished.
- Alternatively, you can also save one morph target per frame, meaning that each morph target represent a step from the transformation. (Some programs can export a movement from objects as an object sequence - a folder consisting of several *.3ds, .obj or .x files. To convert all of them in one step to be used as a morph target, choose the option File > Convert Object Seq to Morph Target.

warper_morph-in-pb_zoom54- In PB, choose which layer (or output) you want to morph between the meshes. First of all assign a media file to it and make sure the opacity is on.
Then go to the Project tab and assign the exported object as a mesh to the layer.

- Go to the "Aeon FX" tab > Folder "Geometry" > drag the effect "Morph A-B" (or "Morph A-B-C)" onto the layer.
Then, again, go to the Project tab and assign the exported morph targets as effect medias. Click on the left image to enlarge it.

- When you have a morph sequence, import it as an image sequence in Pandoras Box or convert it to an *.avi video file, e.g. using the coolux tool Image Converter or to a lossless video format from the coolux codec.
- Go to the "Aeon FX" tab > Folder "Warp" > drag the effect "Warp Target" onto the layer.
- Assign the morph image sequence or video to the effect.